PDA

View Full Version : NShore mechanic


FireWater
09-25-2005, 07:09 PM
This is copied from the boats page (no results there)

Looking for a good shop/mechanic/marina on the north shore

Anyone want to recommend a good mechanic on the north shore ?

Need some help w/ my I/O.

Killed my mint fishing trip today.

Heres the low down if you're interested:

- Ford 351 engine w/ a mercury outdrive.
-1st boat wouldn't start. Just kind of clicked & whined. The after letting it sit and working the throttle a few times it started to turn over and started up. (i'm thinking the throttle or mechanism to put the engine in drive is the culprit)
-I got about 1/2 mi off shore and decided to shut it down and set up for fishing... When I started back up I could get the boat running no problem. But it died when I put it into gear. Tried forward and back ~ 25x over the next hour or so. I tweaked the idle up, down. I put it into gear fast and slow to now result. I finally got a ride in. It plain sucked.
- of note may be that the boat has had an awful time idling and stalls quite a bit going into idle or drive. Also, when put inot reverse anything more than a little throttle and the engine lifts out of the water (been meaning to check this out, dunno if it relates)

Bob Parsons
09-26-2005, 08:45 AM
My first thought would be to check the spark plugs. Might be time to replace them.

The GAFFMAN
09-26-2005, 09:39 AM
Not a Mechanic but had similar problem, Some Mercury throttle mechanism have a nuetral safety switch located on the engine, what it does it momentarily cuts the engine during shifting in to gears N -D or N-R. Sometimes this switch fails or the timing is off on it and it needs replacing. The boat will start however and as soon as you try to go into drive or reverse it will die, sometimes if you try it quickly it will go into gear. I had this problem and replaced the switch, my motor was a Merc. 190 4cyl. not sure if your motor has the same setup. My 2c Cents

FireWater
09-26-2005, 10:18 AM
Errr... I just read my thread. Sorry for the rambling there. I'm surprised anyone could understand it.

I think after talking to a few buds and reading your posts I have a starting point.

Problem is two part:

1) Neutral switch: I agree the neutral switch is going to be replaced. That is why it was cutting out. And probhably why it wouldn't engage the engine to start on the ramp that morning.

2) Fuel suppy: must be gone or going. This I think is due to bad filters/screens/seperators, dirty carb, 31y/o old tank. This explains having to crank up the idle all season to prevent stalling. Going to start w/ cleaning and replacing small stuff and work my way up to the tank thius winter.


Still looking for a mechanic or marina for someone to endorse. So, I have a professional resource for this beast.

It is my 1st boat. And I'm still in the steep learning curve of being an owner. See you out there.

:cool:

CarlL
09-26-2005, 10:36 AM
My brother in law's boat had a some what similar problem. His boat would start and idle fine but as soon as he put it in gear and accelerated, it would stall.

It turned out to be his fuel pump.

codking
09-26-2005, 10:45 AM
Bill Biggart at Biggart Marine in Plaistow NH is one of the best, fairest mechanics I know. Used to service my boat all the time. Now I got diesel and have someone else.
Spike